Installing Cutycapt on Ubuntu 12.0.4

Download PDF

When installing Cutycapt on Ubuntu 12.0.4 you cannot use:

sudo apt-get install subversion libqt4-webkit libqt4-dev g++

but instead you should use

sudo apt-get install subversion libqtwebkit4 libqt4-dev libicu48 g++

Then you can make CutyCapt on Ubuntu without LIB errors missing. /CutyCapt: error while loading shared libraries: libQtSvg.so.4: cannot open shared object file: No such file or directory
make
g++ -c -m64 -pipe -O2 -D_REENTRANT -Wall -W -DQT_WEBKIT -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SVG_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtSvg -I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -I. -o CutyCapt.o CutyCapt.cpp
CutyCapt.cpp: In function ‘int main(int, char**)’:
CutyCapt.cpp:364:7: warning: variable ‘argSilent’ set but not used [-Wunused-but-set-variable]
/usr/bin/moc-qt4 -DQT_WEBKIT -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SVG_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtSvg -I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -I. CutyCapt.hpp -o moc_CutyCapt.cpp
g++ -c -m64 -pipe -O2 -D_REENTRANT -Wall -W -DQT_WEBKIT -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SVG_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtSvg -I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -I. -o moc_CutyCapt.o moc_CutyCapt.cpp
g++ -m64 -Wl,-O1 -o CutyCapt CutyCapt.o moc_CutyCapt.o -L/usr/lib/x86_64-linux-gnu -lQtWebKit -lQtSvg -lQtGui -lQtNetwork -lQtCore -lpthread